Announcement Announcement Module
Collapse
No announcement yet.
How do i reset N900 to factory default - delete all data apps etc? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Don't know then, sorry, presumably it gave you an error message of some kind but I'm not a mind reader so can't say what might be the problem.

    Can only suggest you re-read the Wiki page slowly and carefully.

    Comment


    • #17
      i've tried it again
      1st part says its flashed successfully


      im accuming the 2nd part worked
      it says at the end:

      Raw data transfer EP found at EP2.
      using flashing protocol Mk II.

      Comment


      • #18
        Originally posted by beastkingblast View Post
        i've tried it again
        1st part says its flashed successfully


        im accuming the 2nd part worked
        it says at the end:

        Raw data transfer EP found at EP2.
        using flashing protocol Mk II.
        No, I don't think it has worked.

        Has the N900 booted into Maemo at this stage, or is it in "Flasher" mode (detailed below, and documented in the wiki page)?

        It may be possible to flash the eMMC of a booted device (what state it's left in is anyones guess) but when flashing the firmware the device must not be booted and must be in "Flashing" mode (aka USB mode):
        1. Turn off Maemo device
        2. Press and hold down key 'u' on the physical keyboard
        3. Connect USB cable between Maemo device and host PC while holding down key 'u'
        4. When USB cable gets connected it powers Maemo device and set's it to flashing mode
        5. When the "Nokia" logo appears (the screen will be quite dark) and USB icon appears in the right upper corner, the Maemo device is now in "flashing" mode
        6. Release the 'u' key
        7. Run your two flasher commands and allow the device to reboot into Maemo

        Comment


        • #19
          yep, the screen is dark, has the Nokia icon & the USB symbol

          Comment


          • #20
            got it to work finally yay
            i had to flash them the other way round lol

            Comment


            • #21
              My instructions:

              Code:
              cd "%ProgramFiles%\maemo\flasher-3.5"
              
              flasher-3.5.exe -F RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin -f
              
              flasher-3.5.exe -F RX-51_2009SE_10.2010.19-1.203.1_PR_COMBINED_203_ARM.bin -f -R
              Your comment:

              Originally posted by beastkingblast View Post
              i've tried it again
              1st part says its flashed successfully


              im accuming the 2nd part worked
              it says at the end:

              Raw data transfer EP found at EP2.
              using flashing protocol Mk II.
              The problem you are having appears to relate to the eMMC image (the firmware image doesn't perform a "raw data" transfer) - you should be flashing the eMMC image *first* followed by the firmware image, then reboot the device... if your comment is correct then it seems you have reversed my instructions and are flashing the firmware image first, followed by the eMMC image.

              Does bug 7433 match your problem? They're applying the firmware first, followed by the eMMC as well. Try reversing the order, see if it helps.

              Comment

              Working...
              X